summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/vm-single-partition.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-08-07 15:50:26 +0200
committermakefu <github@syntax-fehler.de>2015-08-07 15:50:26 +0200
commitd38809879df79be835de25d0d7531c8c0eb6423a (patch)
treead491ce214d982d9f1ac92ca7fcb9c5636562d01 /makefu/2configs/vm-single-partition.nix
parent2499c472a08783d1cc1105c9b4c48b04f8062b5b (diff)
parenta919ddb3878c59f1306d8d22f46b603aceb90e27 (diff)
Merge branch 'tsp-vicious'
Diffstat (limited to 'makefu/2configs/vm-single-partition.nix')
-rw-r--r--makefu/2configs/vm-single-partition.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/2configs/vm-single-partition.nix b/makefu/2configs/vm-single-partition.nix
new file mode 100644
index 00000000..78a5e717
--- /dev/null
+++ b/makefu/2configs/vm-single-partition.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+# vda1 ext4 (label nixos) -> only root partition
+with lib;
+{
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/vda";
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-label/nixos";
+ fsType = "ext4";
+ };
+
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+
+}