summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/vm-single-partition.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-08-13 17:09:56 +0200
committertv <tv@shackspace.de>2015-08-13 17:09:56 +0200
commita33f90358d0f57025daddb0ae41d65707fb34cf3 (patch)
tree7f91c889c45fd8995af98d91b0670fb0e90b1d53 /makefu/2configs/vm-single-partition.nix
parent9f92ba455c4b13f4d960bae65cd577c9aad30dc4 (diff)
parent4366ffd6c5d401e3719a588f5ac98365aef8bd89 (diff)
Merge remote-tracking branch 'pnp/master'
Diffstat (limited to 'makefu/2configs/vm-single-partition.nix')
-rw-r--r--makefu/2configs/vm-single-partition.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/2configs/vm-single-partition.nix b/makefu/2configs/vm-single-partition.nix
new file mode 100644
index 00000000..78a5e717
--- /dev/null
+++ b/makefu/2configs/vm-single-partition.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+# vda1 ext4 (label nixos) -> only root partition
+with lib;
+{
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/vda";
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-label/nixos";
+ fsType = "ext4";
+ };
+
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+
+}