summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/remote-build/master.nix
diff options
context:
space:
mode:
authornin <nineinchnade@gmail.com>2017-10-17 19:54:15 +0200
committernin <nineinchnade@gmail.com>2017-10-17 19:54:15 +0200
commit9afe5210f2a44cacac4f3527b6c8b561d9e4296b (patch)
treea83c412966783b123cd3152fe34a6f7cddcb55d6 /makefu/2configs/remote-build/master.nix
parentf4bf9110727f2c7113c80aaa88427b81605016ae (diff)
parent4667bb8e4111abde822ae57993a29929c5cc9aad (diff)
Merge remote-tracking branch 'temp/master'
Diffstat (limited to 'makefu/2configs/remote-build/master.nix')
-rw-r--r--makefu/2configs/remote-build/master.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/makefu/2configs/remote-build/master.nix b/makefu/2configs/remote-build/master.nix
new file mode 100644
index 00000000..4ad2c5ed
--- /dev/null
+++ b/makefu/2configs/remote-build/master.nix
@@ -0,0 +1,14 @@
+{ pkgs, ...}:
+let
+ sshKey = (toString <secrets>) + "/id_nixBuild";
+in {
+ nix.distributedBuilds = true;
+ # TODO: iterate over krebs.hosts
+ nix.buildMachines = map ( hostName:
+ { inherit hostName sshKey;
+ sshUser = "nixBuild";
+ system = "x86_64-linux";
+ maxJobs = 1;
+ }) [ "omo.r" "gum.r" "latte.r" ];
+ # puyak.r "wbob.r"
+}