summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/signal-rest/pkg.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-05-15 14:26:42 +0200
committerlassulus <lassulus@lassul.us>2021-05-15 14:26:42 +0200
commit35aa5ac31dc35f2e14bfb3222ac33381a640ad89 (patch)
tree6a2babb27c771b7e16dca4c4a302fd6e10054e38 /makefu/2configs/home/ham/signal-rest/pkg.nix
parent7e018afe85af22916f070a242d9d1667791e3457 (diff)
parent5bf33d683cbf6f43599ae97aa1c56b1fd0d7d3f3 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/home/ham/signal-rest/pkg.nix')
-rw-r--r--makefu/2configs/home/ham/signal-rest/pkg.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/makefu/2configs/home/ham/signal-rest/pkg.nix b/makefu/2configs/home/ham/signal-rest/pkg.nix
new file mode 100644
index 00000000..165d642a
--- /dev/null
+++ b/makefu/2configs/home/ham/signal-rest/pkg.nix
@@ -0,0 +1,25 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+}:
+
+buildPythonPackage rec {
+ pname = "pysignalclirestapi";
+ version = "0.3.14";
+
+ # disabled = ; # requires python version >=2.7
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "6f3626b594a53c4161dfc67ea7a3b23d62c8fe8cb404a909496118aeefa79cd0";
+ };
+
+ doCheck = false;
+
+ meta = with lib; {
+ description = "Small python library for the Signal Cli REST API";
+ homepage = https://github.com/bbernhard/pysignalclirestapi;
+ #license = licenses.;
+ # maintainers = [ maintainers. ];
+ };
+}