summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/ham/device_tracker/openwrt.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-11-18 22:23:33 +0100
committermakefu <github@syntax-fehler.de>2020-11-18 22:23:33 +0100
commit78fc347be0a0b680bd39a72ac94418d211f5d777 (patch)
tree9e3b7ccd59bb6b1422f5fdc3422e641bd055ea30 /makefu/2configs/ham/device_tracker/openwrt.nix
parente04ae7a3147c731fa3eff16721253cec4dfccdbc (diff)
ma ham: use new home-assistant merge function
Diffstat (limited to 'makefu/2configs/ham/device_tracker/openwrt.nix')
-rw-r--r--makefu/2configs/ham/device_tracker/openwrt.nix23
1 files changed, 13 insertions, 10 deletions
diff --git a/makefu/2configs/ham/device_tracker/openwrt.nix b/makefu/2configs/ham/device_tracker/openwrt.nix
index 8173fcfc..0a34f702 100644
--- a/makefu/2configs/ham/device_tracker/openwrt.nix
+++ b/makefu/2configs/ham/device_tracker/openwrt.nix
@@ -1,10 +1,13 @@
-[
- { platform = "luci";
- host = "192.168.1.5";
- username = "root";
- password = import <secrets/hass/router.nix>;
- interval_seconds = 30; # instead of 12seconds
- consider_home = 300; # 5 minutes timeout
- new_device_defaults.track_new_devices = true;
- }
-]
+{
+ services.home-assistant.config.device_tracker =
+ [
+ { platform = "luci";
+ host = "192.168.1.5";
+ username = "root";
+ password = import <secrets/hass/router.nix>;
+ interval_seconds = 30; # instead of 12seconds
+ consider_home = 300; # 5 minutes timeout
+ new_device_defaults.track_new_devices = true;
+ }
+ ];
+}