summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/ham/automation/moodlight.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-01-27 23:04:10 +0100
committermakefu <github@syntax-fehler.de>2021-01-27 23:04:10 +0100
commit426e0b0c6de8a16228811bf81c467b209b0b3ad7 (patch)
tree167d9668121793e66e219c1c32d54f7c0c7d5a7c /makefu/2configs/ham/automation/moodlight.nix
parent2cd994a1be9934c1b81599b3d90e85c58170be97 (diff)
ma ham: add more automations
Diffstat (limited to 'makefu/2configs/ham/automation/moodlight.nix')
-rw-r--r--makefu/2configs/ham/automation/moodlight.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/makefu/2configs/ham/automation/moodlight.nix b/makefu/2configs/ham/automation/moodlight.nix
new file mode 100644
index 00000000..df229f16
--- /dev/null
+++ b/makefu/2configs/ham/automation/moodlight.nix
@@ -0,0 +1,41 @@
+# uses:
+
+let
+ wohnzimmer = "light.wohnzimmer_fenster_lichterkette_licht";
+ arbeitszimmer = "light.box_led_status";
+ final_off = "01:00";
+
+ turn_on = entity_id: at:
+ { alias = "Turn on ${entity_id} at ${at}";
+ trigger = [
+ { platform = "time"; inherit at; }
+ ];
+ action =
+ [
+ { service = "light.turn_on"; inherit entity_id; }
+ ];
+ };
+in
+{
+ services.home-assistant.config =
+ {
+ automation =
+ [
+ (turn_on wohnzimmer "17:30")
+ (turn_on arbeitszimmer "9:00")
+
+ { alias = "Always turn off the lights at ${final_off}";
+ trigger = [
+ { platform = "time"; at = final_off; }
+ ];
+ action =
+ [
+ {
+ service = "light.turn_off";
+ entity_id = [ wohnzimmer arbeitszimmer];
+ }
+ ];
+ }
+ ];
+ };
+}