summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/ham/androidtv/adbshell.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-03-03 21:12:51 +0100
committermakefu <github@syntax-fehler.de>2020-03-03 21:13:20 +0100
commit2563c59e73dfe9df7b98d5b184785f3a5936ca17 (patch)
treedd8b052a25417681ea989728df28b4913b90ba35 /makefu/2configs/ham/androidtv/adbshell.nix
parent843ee70248752c7b3fc656807bd12b6e6f21f0e1 (diff)
ma ham: use home-assistant from unstable, enable androidtv support
Diffstat (limited to 'makefu/2configs/ham/androidtv/adbshell.nix')
-rw-r--r--makefu/2configs/ham/androidtv/adbshell.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/makefu/2configs/ham/androidtv/adbshell.nix b/makefu/2configs/ham/androidtv/adbshell.nix
new file mode 100644
index 00000000..f5b96c85
--- /dev/null
+++ b/makefu/2configs/ham/androidtv/adbshell.nix
@@ -0,0 +1,38 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, cryptography
+, pyasn1
+, rsa
+, pycryptodome
+}:
+
+buildPythonPackage rec {
+ pname = "adb_shell";
+ version = "0.0.8";
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "01f9jinhfyjldg9793gz2i7gcd9xyx0a62r7a5ijssklcnn2rwnm";
+ };
+
+ propagatedBuildInputs = [
+ cryptography
+ pyasn1
+ rsa
+ ];
+
+ # tests are not part of pypi package
+ doCheck = false;
+
+ checkInputs = [
+ pycryptodome
+ ];
+
+ meta = with lib; {
+ description = "A Python implementation of ADB with shell and FileSync functionality";
+ homepage = https://github.com/JeffLIrion/adb_shell/;
+ license = licenses.mit;
+ # maintainers = [ maintainers. ];
+ };
+}