summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/fetchWallpaper.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-12-13 18:41:51 +0100
committerlassulus <lass@aidsballs.de>2015-12-13 18:41:51 +0100
commite90e346a8647952db70e904ee694775ce3be7abf (patch)
tree6d0be950c4f2b1a7828c9b2186ea61fdf7118f95 /makefu/2configs/fetchWallpaper.nix
parent6ab41de256066d9870a8f2e260781a9a10365a94 (diff)
parent4578f701ba01bfdf0745a8c73461070f0f7d2f0e (diff)
Merge remote-tracking branch 'pnp/master'
Diffstat (limited to 'makefu/2configs/fetchWallpaper.nix')
-rw-r--r--makefu/2configs/fetchWallpaper.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/makefu/2configs/fetchWallpaper.nix b/makefu/2configs/fetchWallpaper.nix
new file mode 100644
index 000000000..b071a128d
--- /dev/null
+++ b/makefu/2configs/fetchWallpaper.nix
@@ -0,0 +1,24 @@
+{ config, pkgs, ... }:
+
+let
+ # check if laptop runs on umts
+ weaksauce-internet = with pkgs;writeScript "weaksauce-internet" ''
+ #! /bin/sh
+ if ${iproute}/bin/ip addr show dev ppp0 2>/dev/null \
+ | ${gnugrep}/bin/grep -q inet;then
+ exit 1
+ fi
+ '';
+
+in {
+ krebs.fetchWallpaper = {
+ enable = true;
+ display = ":0";
+ predicate = weaksauce-internet;
+ timerConfig = {
+ OnCalendar = "*:0/30";
+ };
+ url = "http://echelon/wallpaper.png";
+ };
+}
+