summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/elchos/irc-token.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2016-12-29 11:58:45 +0100
committerlassulus <lass@lassul.us>2016-12-29 11:58:45 +0100
commit6e81f6f528ff333d471656a73631bf72736cc944 (patch)
treedd21f85ad4231b6e4d8a165f14b2eed5ffe7c680 /makefu/2configs/elchos/irc-token.nix
parent38b11b5ba4423421adeb13f5c510286587080627 (diff)
parent4fcc9718c99b403bd11398c89ae2f0c81ddd9ac8 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/elchos/irc-token.nix')
-rw-r--r--makefu/2configs/elchos/irc-token.nix27
1 files changed, 21 insertions, 6 deletions
diff --git a/makefu/2configs/elchos/irc-token.nix b/makefu/2configs/elchos/irc-token.nix
index 3f3c4ffc..a91223b2 100644
--- a/makefu/2configs/elchos/irc-token.nix
+++ b/makefu/2configs/elchos/irc-token.nix
@@ -3,19 +3,20 @@ with import <stockholm/lib>;
let
secret = (import <secrets/elchos-token.nix>);
in {
- systemd.services.elchos-irctoken = {
- startAt = "*:0/30";
+ systemd.services.elchos-irctoken2 = {
+ startAt = "*:0/5";
serviceConfig = {
RuntimeMaxSec = "20";
};
script = ''
set -euf
now=$(date -u +%Y-%m-%dT%H:%M)
- sec=$(echo -n "${secret}$now" | md5sum | cut -d\ -f1)
- message="The secret valid for 30 minutes is $sec"
- echo "token for $now (UTC) is $sec"
+ sleep 5
+ sec=$(cat /tmp/irc-secret)
+ message="The current secret is $sec"
+ echo "$message"
LOGNAME=sec-announcer
- HOSTNAME=$(${pkgs.systemd}/bin/hostnamectl --static)
+ HOSTNAME=$(${pkgs.systemd}/bin/hostnamectl --transient)
IRC_SERVER=irc.freenode.net
IRC_PORT=6667
IRC_NICK=$HOSTNAME-$$
@@ -59,4 +60,18 @@ in {
| ${pkgs.netcat}/bin/netcat "$IRC_SERVER" "$IRC_PORT" |tee -a ircin
'';
};
+ systemd.services.elchos-create-token = {
+ startAt = "*:0/30";
+ serviceConfig = {
+ RuntimeMaxSec = "20";
+ };
+ script = ''
+ set -euf
+ now=$(date -u +%Y-%m-%dT%H:%M)
+ sec=$(echo -n "${secret}$now" | md5sum | cut -d\ -f1)
+ message="The secret valid for 30 minutes is $sec"
+ echo -n "$sec" > /tmp/irc-secret
+ echo "token for $now (UTC) is $sec"
+ '';
+ };
}