summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/hound/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-06-04 06:20:54 +0200
committertv <tv@krebsco.de>2017-06-04 06:20:54 +0200
commit811ceaa243bf5241ca1189871c4426240962f04d (patch)
treef46006567b5f9279ebd9cb23de3eadb508f83c54 /makefu/2configs/deployment/hound/default.nix
parent4f58b884dda57db8106768a22a206d6605d6e3e5 (diff)
parente50bc4f3eb3dac13bba4ae6158e839a52455c3c3 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'makefu/2configs/deployment/hound/default.nix')
-rw-r--r--makefu/2configs/deployment/hound/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/makefu/2configs/deployment/hound/default.nix b/makefu/2configs/deployment/hound/default.nix
new file mode 100644
index 00000000..0cfb5cde
--- /dev/null
+++ b/makefu/2configs/deployment/hound/default.nix
@@ -0,0 +1,28 @@
+{ config, pkgs, ... }:
+{
+ services.nginx.virtualHosts."wikisearch.krebsco.de" = {
+ forceSSL = true;
+ enableACME = true;
+ locations."/".proxyPass = "http://localhost:6080";
+ };
+ services.hound = {
+ enable = true;
+ listen = "127.0.0.1:6080";
+ # package = pkgs.hound.overrideDerivation(oldAttrs: {
+ # patches = [ ./keep-repo.patch ];
+ # });
+ config = ''{
+ "max-concurrent-indexers" : 2,
+ "dbpath" : "${config.services.hound.home}/data",
+ "repos" : {
+ "nixos-users-wiki": {
+ "url" : "https://github.com/nixos-users/wiki.wiki.git",
+ "url-pattern" : {
+ "base-url" : "{url}/{path}"
+ }
+ }
+ }
+ }'';
+ };
+
+}