summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/cgit-retiolum.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-09-02 10:02:05 +0200
committermakefu <github@syntax-fehler.de>2015-09-02 10:02:05 +0200
commit37744f0016b77af41e8f57bc6da32b15f5ac50fd (patch)
treef51174cd0c20364eb9f4b03342dbaed7250a7729 /makefu/2configs/cgit-retiolum.nix
parentf911d43005d043ca360837eb8b3c2c2fe30bc962 (diff)
makefu: sort 2configs
Diffstat (limited to 'makefu/2configs/cgit-retiolum.nix')
-rw-r--r--makefu/2configs/cgit-retiolum.nix79
1 files changed, 0 insertions, 79 deletions
diff --git a/makefu/2configs/cgit-retiolum.nix b/makefu/2configs/cgit-retiolum.nix
deleted file mode 100644
index a40dabb3..00000000
--- a/makefu/2configs/cgit-retiolum.nix
+++ /dev/null
@@ -1,79 +0,0 @@
-{ config, lib, pkgs, ... }:
-# TODO: remove tv lib :)
-with import ../../tv/4lib { inherit lib pkgs; };
-let
-
- repos = priv-repos // krebs-repos ;
- rules = concatMap krebs-rules (attrValues krebs-repos) ++ concatMap priv-rules (attrValues priv-repos);
-
- krebs-repos = mapAttrs make-krebs-repo {
- stockholm = {
- desc = "Make all the systems into 1systems!";
- };
- };
-
- priv-repos = mapAttrs make-priv-repo {
- autosync = { };
- };
-
-
- # TODO move users to separate module
- make-priv-repo = name: { desc ? null, ... }: {
- inherit name desc;
- public = false;
- };
-
- make-krebs-repo = with git; name: { desc ? null, ... }: {
- inherit name desc;
- public = true;
- hooks = {
- post-receive = git.irc-announce {
- nick = config.networking.hostName;
- channel = "#retiolum";
- # TODO remove the hardcoded hostname
- server = "cd.retiolum";
- };
- };
- };
-
- set-owners = with git;repo: user:
- singleton {
- inherit user;
- repo = [ repo ];
- perm = push "refs/*" [ non-fast-forward create delete merge ];
- };
-
- set-ro-access = with git; repo: user:
- optional repo.public {
- inherit user;
- repo = [ repo ];
- perm = fetch;
- };
-
- # TODO: get the list of all krebsministers
- krebsminister = with config.krebs.users; [ lass tv uriel ];
- all-makefu = with config.krebs.users; [ makefu makefu-omo makefu-tsp ];
-
- priv-rules = repo: set-owners repo all-makefu;
-
- krebs-rules = repo:
- set-owners repo all-makefu ++ set-ro-access repo krebsminister;
-
-in {
- imports = [{
- krebs.users.makefu-omo = {
- name = "makefu-omo" ;
- pubkey= with builtins; readFile ../../krebs/Zpubkeys/makefu_omo.ssh.pub;
- };
- krebs.users.makefu-tsp = {
- name = "makefu-tsp" ;
- pubkey= with builtins; readFile ../../krebs/Zpubkeys/makefu_tsp.ssh.pub;
- };
- }];
- krebs.git = {
- enable = true;
- root-title = "public repositories";
- root-desc = "keep on krebsing";
- inherit repos rules;
- };
-}