summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/switch/tasmota_switch.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2019-04-09 20:12:06 +0200
committerjeschli <jeschli@gmail.com>2019-04-09 20:12:06 +0200
commita4be985644762dcc2750a366db5780687690ef7d (patch)
tree5bc270cec7c01b986cd146769bc94bf2268c4113 /makefu/2configs/bureautomation/switch/tasmota_switch.nix
parentcb03267e0c3fd3bfa4beaa454f8986856a93963f (diff)
parent7e1b197dab13d024ba491c96dc959306324943c0 (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'makefu/2configs/bureautomation/switch/tasmota_switch.nix')
-rw-r--r--makefu/2configs/bureautomation/switch/tasmota_switch.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/makefu/2configs/bureautomation/switch/tasmota_switch.nix b/makefu/2configs/bureautomation/switch/tasmota_switch.nix
index b00a8e45..115bae0c 100644
--- a/makefu/2configs/bureautomation/switch/tasmota_switch.nix
+++ b/makefu/2configs/bureautomation/switch/tasmota_switch.nix
@@ -2,18 +2,21 @@ let
tasmota_plug = name: topic:
{ platform = "mqtt";
inherit name;
- state_topic = "/bam/${topic}/stat/POWER";
+ state_topic = "/bam/${topic}/tele/STATE";
+ value_template = "{{ value_json.POWER }}";
command_topic = "/bam/${topic}/cmnd/POWER";
availability_topic = "/bam/${topic}/tele/LWT";
payload_on= "ON";
payload_off= "OFF";
payload_available= "Online";
payload_not_available= "Offline";
+ retain = false;
+ qos = 1;
};
in [
(tasmota_plug "Bauarbeiterlampe" "plug")
(tasmota_plug "Blitzdings" "plug2")
(tasmota_plug "Fernseher" "plug3")
(tasmota_plug "Feuer" "plug4")
- (tasmota_plug "Nachtlicht" "plug5")
+ (tasmota_plug "Blaulicht" "plug5")
]