summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/sensor/tasmota_firmware.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2019-04-23 20:15:10 +0200
committerjeschli <jeschli@gmail.com>2019-04-23 20:15:10 +0200
commit35fdfbe5ccb3b5844b62ac2486352107484e75d4 (patch)
tree561ff21ae90ce6826ab3d74ebd9f27dee7054a0d /makefu/2configs/bureautomation/sensor/tasmota_firmware.nix
parenta4be985644762dcc2750a366db5780687690ef7d (diff)
parentcd825d99342050bae35d5373e927ca999bae82cf (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'makefu/2configs/bureautomation/sensor/tasmota_firmware.nix')
-rw-r--r--makefu/2configs/bureautomation/sensor/tasmota_firmware.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/sensor/tasmota_firmware.nix b/makefu/2configs/bureautomation/sensor/tasmota_firmware.nix
new file mode 100644
index 00000000..1a4738e1
--- /dev/null
+++ b/makefu/2configs/bureautomation/sensor/tasmota_firmware.nix
@@ -0,0 +1,16 @@
+let
+ tasmota_firmware = topic:
+ { platform = "mqtt";
+ name = "${topic} Firmware";
+ state_topic = "/bam/${topic}/stat/STATUS2";
+ availability_topic = "/bam/${topic}/tele/LWT";
+ value_template = "v{{value_json.StatusFWR.Version}}";
+ payload_available= "Online";
+ payload_not_available= "Offline";
+ };
+in
+ map tasmota_firmware [
+ "plug" "plug2" "plug3" "plug4" "plug5"
+ "status1" "status2" "buslicht"
+ "rfbridge"
+ ]