summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/Reaktor/shack-correct.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-09 14:48:58 +0200
committertv <tv@shackspace.de>2015-10-09 14:48:58 +0200
commit96f4248b65ff1539eded24572ae1805b27c53d50 (patch)
tree31ff450cc4a5166306c62f99fdd2d1caf3219ecb /makefu/2configs/Reaktor/shack-correct.nix
parent694c79a5bc05014604fa2467f965b370102ff78f (diff)
parent4072a32f89b9cc1c1e7c3583ac5b9ce5dcb004af (diff)
Merge remote-tracking branch 'cloudkrebs/master'
Diffstat (limited to 'makefu/2configs/Reaktor/shack-correct.nix')
-rw-r--r--makefu/2configs/Reaktor/shack-correct.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/2configs/Reaktor/shack-correct.nix b/makefu/2configs/Reaktor/shack-correct.nix
new file mode 100644
index 00000000..8f30807f
--- /dev/null
+++ b/makefu/2configs/Reaktor/shack-correct.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+with pkgs;
+let
+ script = pkgs.substituteAll ( {
+ name="shack-correct";
+ isExecutable=true;
+ dir = "";
+ src = ./shack-correct.sh;
+ });
+in {
+ krebs.Reaktor.extraConfig = ''
+ public_commands.insert(0,{
+ 'capname' : "shack-correct",
+ 'pattern' : '^(?P<args>.*Shack.*)$$',
+ 'argv' : ["${script}"],
+ 'env' : { }})
+ '';
+}
+