summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/Reaktor/shack-correct.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-10-08 17:00:19 +0200
committerlassulus <lass@aidsballs.de>2015-10-08 17:00:19 +0200
commitef85f86f8ad113a3e01e16952a844fb16f810f7e (patch)
tree2a2faddc28117ffccb3c27628f2fd8d5caacd668 /makefu/2configs/Reaktor/shack-correct.nix
parent892c99706a1c997ae064e443c2162a5659b8a05e (diff)
parent5f5c1f5f661a2c4236fb62bc4c0ec7d43ae7a5b1 (diff)
Merge remote-tracking branch 'pnp/master'
Diffstat (limited to 'makefu/2configs/Reaktor/shack-correct.nix')
-rw-r--r--makefu/2configs/Reaktor/shack-correct.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/2configs/Reaktor/shack-correct.nix b/makefu/2configs/Reaktor/shack-correct.nix
new file mode 100644
index 00000000..8f30807f
--- /dev/null
+++ b/makefu/2configs/Reaktor/shack-correct.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+with pkgs;
+let
+ script = pkgs.substituteAll ( {
+ name="shack-correct";
+ isExecutable=true;
+ dir = "";
+ src = ./shack-correct.sh;
+ });
+in {
+ krebs.Reaktor.extraConfig = ''
+ public_commands.insert(0,{
+ 'capname' : "shack-correct",
+ 'pattern' : '^(?P<args>.*Shack.*)$$',
+ 'argv' : ["${script}"],
+ 'env' : { }})
+ '';
+}
+