summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/wbob.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-01-23 00:29:55 +0100
committermakefu <github@syntax-fehler.de>2016-01-23 00:29:55 +0100
commite91ee6132671d874c817d5569a618472b5a710ca (patch)
tree60422048d6d8a532a1c30cbeba3ebd6c35367ee8 /makefu/1systems/wbob.nix
parent7cf54a1d791fff716968a145feb55f28b84aef76 (diff)
parented4e0241d5aba830f31a7271435c93c7299b884b (diff)
Merge branch 'master' of gum:stockholm
Diffstat (limited to 'makefu/1systems/wbob.nix')
-rw-r--r--makefu/1systems/wbob.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/makefu/1systems/wbob.nix b/makefu/1systems/wbob.nix
new file mode 100644
index 00000000..d6916f00
--- /dev/null
+++ b/makefu/1systems/wbob.nix
@@ -0,0 +1,19 @@
+{ config, pkgs, ... }:
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ ../2configs/main-laptop.nix
+ ];
+ krebs = {
+ enable = true;
+ retiolum.enable = true;
+ build.host = config.krebs.hosts.wbob;
+ };
+ boot.loader.grub.device = "/dev/sda";
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "usbhid" "usb_storage" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ fileSystems."/" = {
+ device = "/dev/sda1";
+ fsType = "ext4";
+ };
+}