summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/vbob/config.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-07-16 12:05:35 +0200
committerlassulus <lassulus@lassul.us>2017-07-16 12:05:35 +0200
commitcd7c0971ccc9023f63feb75d4abe514fdc03a079 (patch)
tree704c47afe8cd43a36f36f251cd53b340ec5ec4da /makefu/1systems/vbob/config.nix
parentb91a4c4b0f0958cdc5e7c0d60523326083f275d4 (diff)
parent0e0ad14c373a038e6d347017f5efe172c7409793 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/1systems/vbob/config.nix')
-rw-r--r--makefu/1systems/vbob/config.nix73
1 files changed, 73 insertions, 0 deletions
diff --git a/makefu/1systems/vbob/config.nix b/makefu/1systems/vbob/config.nix
new file mode 100644
index 00000000..933fcf04
--- /dev/null
+++ b/makefu/1systems/vbob/config.nix
@@ -0,0 +1,73 @@
+{ lib, config, pkgs, ... }:
+{
+ krebs.build.host = config.krebs.hosts.vbob;
+ makefu.awesome.modkey = "Mod1";
+ imports =
+ [ # Include the results of the hardware scan.
+ <stockholm/makefu>
+ (toString <nixpkgs/nixos/modules/virtualisation/virtualbox-image.nix>)
+ (toString <nixpkgs/nixos/modules/virtualisation/virtualbox-guest.nix>)
+ <stockholm/makefu/2configs/main-laptop.nix #< base-gui>
+ <stockholm/makefu/2configs/sshd-totp.nix>
+
+ # Tools
+ <stockholm/makefu/2configs/tools/core.nix>
+ <stockholm/makefu/2configs/tools/core-gui.nix>
+ <stockholm/makefu/2configs/tools/dev.nix>
+ <stockholm/makefu/2configs/tools/extra-gui.nix>
+ <stockholm/makefu/2configs/tools/sec.nix>
+
+ # environment
+ <stockholm/makefu/2configs/tinc/retiolum.nix>
+
+ <stockholm/makefu/2configs/audio/jack-on-pulse.nix>
+ <stockholm/makefu/2configs/audio/realtime-audio.nix>
+
+ ];
+ networking.extraHosts = import (toString <secrets/extra-hosts.nix>);
+
+ nixpkgs.config.allowUnfree = true;
+ fileSystems."/nix" = {
+ device ="/dev/disk/by-label/nixstore";
+ fsType = "ext4";
+ };
+
+ # allow vbob to deploy self
+ users.extraUsers = {
+ root = {
+ openssh.authorizedKeys.keys = [ config.krebs.users.makefu-vbob.pubkey ];
+ };
+ };
+
+ environment.shellAliases = {
+ forti = "cat ~/vpn/pw.txt | xclip; sudo forticlientsslvpn";
+ };
+ # TODO: for forticleintsslpn
+ # ln -s /r/current-system/sw/bin/pppd /usr/sbin/pppd
+ # ln -s /r/current-system/sw/bin/tail /usr/bin/tail
+ environment.systemPackages = with pkgs;[
+ fortclientsslvpn ppp xclip
+ get
+ logstash
+ # docker
+ #devpi-web
+ #devpi-client
+ debmirror
+ ansible
+ ];
+ # virtualisation.docker.enable = true;
+
+
+ networking.firewall.allowedTCPPorts = [
+ 25
+ 80
+ 8010
+ ];
+
+ fileSystems."/media/share" = {
+ fsType = "vboxsf";
+ device = "share";
+ options = [ "rw" "uid=9001" "gid=9001" ];
+ };
+
+}