summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/vbob.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-07-18 12:15:50 +0200
committerlassulus <lass@aidsballs.de>2016-07-18 12:15:50 +0200
commitaf1959e3bdaabc004663c2dc2120148c18aa6b7c (patch)
treee9f5237e90903a3a1fede41dc2300cffd405e817 /makefu/1systems/vbob.nix
parenta71a9ed33a92ba901f7c605506bb2c3ee506e6c7 (diff)
parent33c96a89c5c72218a1c9f16bcea5909cd5135768 (diff)
Merge remote-tracking branch 'gum/master' into new-populate
Diffstat (limited to 'makefu/1systems/vbob.nix')
-rw-r--r--makefu/1systems/vbob.nix20
1 files changed, 8 insertions, 12 deletions
diff --git a/makefu/1systems/vbob.nix b/makefu/1systems/vbob.nix
index 8b71b139..3fcb173c 100644
--- a/makefu/1systems/vbob.nix
+++ b/makefu/1systems/vbob.nix
@@ -5,23 +5,23 @@
imports =
[ # Include the results of the hardware scan.
../.
- <nixpkgs/nixos/modules/virtualisation/virtualbox-image.nix>
+ (toString <nixpkgs/nixos/modules/virtualisation/virtualbox-image.nix>)
+ (toString <nixpkgs/nixos/modules/virtualisation/virtualbox-guest.nix>)
../2configs/main-laptop.nix #< base-gui
+ # (toString <secrets>)/extra-hosts.nix
# environment
];
- nixpkgs.config.allowUnfree = true;
+ # workaround for https://github.com/NixOS/nixpkgs/issues/16641
+ services.xserver.videoDrivers = lib.mkOverride 45 [ "virtualbox" "modesetting" ];
+ nixpkgs.config.allowUnfree = true;
fileSystems."/nix" = {
device ="/dev/disk/by-label/nixstore";
fsType = "ext4";
};
- fileSystems."/var/lib/docker" = {
- device ="/dev/disk/by-label/nix-docker";
- fsType = "ext4";
- };
- #makefu.buildbot.master.enable = true;
+
# allow vbob to deploy self
users.extraUsers = {
root = {
@@ -52,11 +52,7 @@
"gum"
];
};
-
- networking.extraHosts = ''
- 172.17.20.190 gitlab
- 172.17.62.27 svbittool01 tool
- '';
+ virtualisation.docker.enable = false;
fileSystems."/media/share" = {
fsType = "vboxsf";