summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/studio.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-07-15 18:57:16 +0200
committermakefu <github@syntax-fehler.de>2017-07-15 18:57:16 +0200
commitfa38155eec9563dc9dc620a77900d87b97443cfe (patch)
tree6000436cba63e03a21556fb6c2d6ebb67eb5b3b0 /makefu/1systems/studio.nix
parent3698f2a40c2db7df0888974c9b2e347947088a98 (diff)
ma: move systems to subdir, init source
Diffstat (limited to 'makefu/1systems/studio.nix')
-rw-r--r--makefu/1systems/studio.nix77
1 files changed, 0 insertions, 77 deletions
diff --git a/makefu/1systems/studio.nix b/makefu/1systems/studio.nix
deleted file mode 100644
index f7d49cac..00000000
--- a/makefu/1systems/studio.nix
+++ /dev/null
@@ -1,77 +0,0 @@
-{ config, pkgs, ... }:
-{
- imports = [
- ../.
- ../2configs/vncserver.nix
- ../2configs/vim.nix
- ../2configs/disable_v6.nix
- ../2configs/audio/jack-on-pulse.nix
- ../2configs/audio/realtime-audio.nix
- ../2configs/gui/studio.nix
- ../2configs/binary-cache/lass.nix
-
- ];
- makefu.gui.user = "user"; # we use an extra user
- krebs = {
- enable = true;
- tinc.retiolum.enable = true;
- build.host = config.krebs.hosts.studio;
- };
- networking.firewall.allowedTCPPorts = [ 655 ];
- networking.firewall.allowedUDPPorts = [ 655 ];
-
-
- environment.systemPackages = with pkgs;[
- # audio foo
- ## pulseaudio
- pavucontrol
- paprefs
- pamixer
-
- # extra alsa tools
- alsa-hdspconf
- alsa-hdspmixer
- alsa-hdsploader
-
- # recording
- darkice
- (mumble.override { jackSupport = true; })
-
- # browsing
- firefox
- chromium
- ];
-
-
- nixpkgs.config.allowUnfree = true;
- fonts = {
- enableCoreFonts = true;
- enableFontDir = true;
- enableGhostscriptFonts = true;
- fonts = [ ];
- };
- # ingos favorite display manager
-
-
- # hardware
- boot.loader.grub.enable = true;
- boot.loader.grub.version = 2;
- boot.loader.grub.device = "/dev/sda";
-
- boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ata_piix" "usb_storage" "sd_mod" ];
- boot.kernelModules = [ ];
- boot.extraModulePackages = [ ];
-
- fileSystems."/" = {
- device = "/dev/disk/by-uuid/0aeda516-230e-4c54-9e27-13515c2f3f21";
- fsType = "ext4";
- };
-
- swapDevices = [ { device = "/dev/disk/by-uuid/1914af67-5a8f-41d3-a1c2-211c39605da9"; } ];
- users.users.user = {
- isNormalUser = true;
- extraGroups = [ "wheel" "audio" ];
- uid = 1000;
- openssh.authorizedKeys.keys = [ config.krebs.users.makefu.pubkey ];
- };
-}