summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/omo/hw/tsp.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-09-16 02:11:05 +0200
committertv <tv@krebsco.de>2018-09-16 02:11:05 +0200
commit45c39cddad6d8d2d65b3a145648611c1e9c78737 (patch)
tree66f5ed7d2f09bf422b0e3128fadf449da428858e /makefu/1systems/omo/hw/tsp.nix
parent5487d466d0d9b596b054c545b499aecbbe56b5aa (diff)
parent0b3497384e7e67e734f5f771fcb5aa649ad964d2 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'makefu/1systems/omo/hw/tsp.nix')
-rw-r--r--makefu/1systems/omo/hw/tsp.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/makefu/1systems/omo/hw/tsp.nix b/makefu/1systems/omo/hw/tsp.nix
new file mode 100644
index 00000000..4af0d73f
--- /dev/null
+++ b/makefu/1systems/omo/hw/tsp.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }:
+with builtins;
+let
+ disko = import (builtins.fetchGit {
+ url = https://cgit.lassul.us/disko/;
+ rev = "9c9b62e15e4ac11d4379e66b974f1389daf939fe";
+ });
+ cfg = fromJSON (readFile ../../hardware/tsp-disk.json);
+ primaryInterface = "enp1s0";
+ rootDisk = "/dev/sda"; # TODO same as disko uses
+in {
+ imports = [
+ (disko.config cfg)
+ ];
+ makefu.server.primary-itf = primaryInterface;
+ boot = {
+ loader.grub.device = rootDisk;
+
+ initrd.availableKernelModules = [
+ "ahci"
+ "ohci_pci"
+ "ehci_pci"
+ "pata_atiixp"
+ "firewire_ohci"
+ "usb_storage"
+ "usbhid"
+ ];
+
+ kernelModules = [ "kvm-intel" ];
+ };
+
+}