summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2020-09-08 22:04:21 +0200
committerlassulus <lassulus@lassul.us>2020-09-08 22:04:21 +0200
commit32a5fd32c8a06084ee06d57cb2feeac0b14b380d (patch)
treec33c4e9d8da1ba419541950f110f4b4dfbf8155b /lib/types.nix
parent549598bfd9cf6e94f8bb83ebbcc17400069f1198 (diff)
parent6fbbf7e6170f6a1ba42c5dcecd11ca67c6bc5afd (diff)
Merge remote-tracking branch 'ni/master' into HEAD
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 1eb4d947..3eda2262 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -179,6 +179,10 @@ rec {
pubkey = mkOption {
type = tinc-pubkey;
};
+ pubkey_ed25519 = mkOption {
+ type = nullOr tinc-pubkey;
+ default = null;
+ };
extraConfig = mkOption {
description = "Extra Configuration to be appended to the hosts file";
default = "";