summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-04-23 16:59:07 +0200
committermakefu <github@syntax-fehler.de>2020-04-23 16:59:07 +0200
commit07ab7b9519b6b5f253690101571f8fa12f20f4da (patch)
treeddb78a201c98177293c80135710b6c8b8e9025f2 /lib/types.nix
parent5b0d6c30d0bde6254d995a0c9b58b2ef70f16594 (diff)
parent0fbf9144d4bf93840faa49c7743e3273337bed0f (diff)
Merge remote-tracking branch 'lass/master' into 20.03
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/types.nix b/lib/types.nix
index ffae8c7b..16ccb145 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -7,7 +7,7 @@ let
mkOptionType optional optionalAttrs optionals range splitString
stringLength substring test testString typeOf;
inherit (lib.types)
- attrsOf bool either enum int listOf nullOr path str string submodule;
+ attrsOf bool either enum int listOf nullOr path str submodule;
in
rec {
@@ -65,7 +65,7 @@ rec {
extraZones = mkOption {
default = {};
# TODO: string is either MX, NS, A or AAAA
- type = attrsOf string;
+ type = attrsOf str;
};
secure = mkOption {
@@ -182,7 +182,7 @@ rec {
extraConfig = mkOption {
description = "Extra Configuration to be appended to the hosts file";
default = "";
- type = string;
+ type = str;
};
port = mkOption {
type = int;