summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-06-14 19:32:37 +0200
committerlassulus <lass@aidsballs.de>2015-06-14 19:32:37 +0200
commit84d5eb4174a5bc64d47736b691d09ded5d167575 (patch)
treeefcd15bfaf9ba1f4a45da57b104c88078769111b /lib/default.nix
parent35d0fd6164eb5e18f69c353d11ab1e48c066abd3 (diff)
parentbff3b50dddb1bb37831d9f17ca25ccab7f7476fe (diff)
Merge branch 'master' of nomic:config
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix18
1 files changed, 14 insertions, 4 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 995e3dbc..27cf0e25 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -1,16 +1,26 @@
-{ pkgs, ... }:
+{ lib, ... }:
with builtins;
let
- inherit (pkgs.lib) stringAsChars;
+ inherit (lib) mapAttrs stringAsChars;
in
-{
+rec {
+ git = import ./git.nix {
+ lib = lib // {
+ inherit addNames;
+ };
+ };
+
+ addName = name: set:
+ set // { inherit name; };
+
+ addNames = mapAttrs addName;
# "7.4.335" -> "74"
- majmin = with pkgs.lib; x : concatStrings (take 2 (splitString "." x));
+ majmin = with lib; x : concatStrings (take 2 (splitString "." x));
concat = xs :