summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/untilport/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-05-20 00:12:43 +0200
committerlassulus <lass@aidsballs.de>2016-05-20 00:12:43 +0200
commit3fea8d651f49ac6a57f99bc6b49a5689e3c74fd8 (patch)
treedfbecc2dba43af743d39ec95a94bbbc72082b986 /lass/5pkgs/untilport/default.nix
parent0fd95b3228ac1ba7e4e18e4207691ce401471e6a (diff)
l: add untilport
Diffstat (limited to 'lass/5pkgs/untilport/default.nix')
-rw-r--r--lass/5pkgs/untilport/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/lass/5pkgs/untilport/default.nix b/lass/5pkgs/untilport/default.nix
new file mode 100644
index 00000000..61bcc2b8
--- /dev/null
+++ b/lass/5pkgs/untilport/default.nix
@@ -0,0 +1,18 @@
+{ pkgs, ... }:
+
+pkgs.writeDashBin "untilport" ''
+ set -euf
+
+ usage() {
+ echo 'untiport $target $port'
+ echo 'Sleeps until the destinated port is reachable.'
+ echo 'ex: untilport google.de 80 && echo "google is now reachable"'
+ }
+
+
+ if [ $# -ne 2 ]; then
+ usage
+ else
+ until ${pkgs.netcat-openbsd}/bin/nc -z "$@"; do sleep 1; done
+ fi
+''