summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/firefoxPlugins/ublock.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-10-01 18:49:34 +0200
committermakefu <github@syntax-fehler.de>2015-10-01 18:49:34 +0200
commit49c00cf74f778152f4aed943dedb7bbf283b16e7 (patch)
tree29946a2fedb005b68a417acf3ac04d6f858f8aa1 /lass/5pkgs/firefoxPlugins/ublock.nix
parent73aa31010415ac5f7bf86d2bb77099fc3097905a (diff)
parent4af4fa89e50c3769d9331608cec2e6752ceb4fcb (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'lass/5pkgs/firefoxPlugins/ublock.nix')
-rw-r--r--lass/5pkgs/firefoxPlugins/ublock.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/lass/5pkgs/firefoxPlugins/ublock.nix b/lass/5pkgs/firefoxPlugins/ublock.nix
new file mode 100644
index 00000000..29ef250e
--- /dev/null
+++ b/lass/5pkgs/firefoxPlugins/ublock.nix
@@ -0,0 +1,31 @@
+{ fetchgit, stdenv, bash, python, zip }:
+
+stdenv.mkDerivation rec {
+ name = "ublock";
+ id = "{2b10c1c8-a11f-4bad-fe9c-1c11e82cac42}";
+
+ src = fetchgit {
+ url = "https://github.com/chrisaljoudi/uBlock";
+ rev = "a70a50052a7914cbf86d46a725812b98434d8c70";
+ sha256 = "1qfzy79f8x01i33x0m95k833z1jgxjwb8wvlr6fj6id1kxfvzh77";
+ };
+
+ buildInputs = [
+ zip
+ python
+ ];
+
+ patchPhase = ''
+ substituteInPlace "tools/make-firefox.sh" \
+ --replace "/bin/bash" "${bash}/bin/bash"
+ '';
+
+ buildPhase = ''
+ tools/make-firefox.sh all
+ '';
+
+ installPhase = ''
+ mkdir -p $out/
+ cp dist/build/uBlock.firefox.xpi $out/${id}.xpi
+ '';
+}