summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/emot-menu/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-12-05 16:41:38 +0100
committermakefu <github@syntax-fehler.de>2018-12-05 16:41:38 +0100
commita4556a17f6639efe13e709bf53af15bb2a70c82d (patch)
treec81f829077d32fce39baaf7bfa526d8cac071879 /lass/5pkgs/emot-menu/default.nix
parent1859d6653a12e1bfda9465780610f63da8f5ce69 (diff)
parente4750d38e76db94a0b255fa143408b8cbe38b61b (diff)
Merge remote-tracking branch 'lass/master' into HEAD
Diffstat (limited to 'lass/5pkgs/emot-menu/default.nix')
-rw-r--r--lass/5pkgs/emot-menu/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/lass/5pkgs/emot-menu/default.nix b/lass/5pkgs/emot-menu/default.nix
new file mode 100644
index 00000000..d5d84e45
--- /dev/null
+++ b/lass/5pkgs/emot-menu/default.nix
@@ -0,0 +1,31 @@
+{ coreutils, dmenu, gnused, writeDashBin, writeText, xdotool }: let
+
+ emoticons = writeText "emoticons" ''
+¯\(°_o)/¯ | dunno lol shrug dlol
+¯\_(ツ)_/¯ | dunno lol shrug dlol
+( ͡° ͜ʖ ͡°) | lenny
+¯\_( ͡° ͜ʖ ͡°)_/¯ | lenny shrug dlol
+( ゚д゚) | aaah sad noo
+ヽ(^o^)丿 | hi yay hello
+(^o^; | ups hehe
+(^∇^) | yay
+┗(`皿´)┛ | angry argh
+ヾ(^_^) byebye!! | bye
+<(^.^<) <(^.^)> (>^.^)> (7^.^)7 (>^.^<) | dance
+(-.-)Zzz... | sleep
+(∩╹□╹∩) | oh noes woot
+™ | tm
+ζ | zeta
+(╯°□°)╯ ┻━┻ | table flip
+(」゜ロ゜)」 | why woot
+ '';
+
+in
+writeDashBin "emoticons" ''
+ set -efu
+
+ data=$(${coreutils}/bin/cat ${emoticons})
+ emoticon=$(echo "$data" | ${dmenu}/bin/dmenu | ${gnused}/bin/sed 's/ | .*//')
+ ${xdotool}/bin/xdotool type -- "$emoticon"
+ exit 0
+''