summaryrefslogtreecommitdiffstats
path: root/lass/3modules/static_nginx.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-04-07 20:29:33 +0200
committertv <tv@krebsco.de>2016-04-07 20:29:33 +0200
commite1a287c78bab2847fee7c4f1a18a765d89ca373f (patch)
tree336fc62199af9b1c38acf2de0a2bafbe8ed72efc /lass/3modules/static_nginx.nix
parent033bf438bd2ae39d6a465c475500a24514cc2739 (diff)
parent66b7a76a26a40bd4ecca8c83aafe5f2e5fefa461 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'lass/3modules/static_nginx.nix')
-rw-r--r--lass/3modules/static_nginx.nix15
1 files changed, 1 insertions, 14 deletions
diff --git a/lass/3modules/static_nginx.nix b/lass/3modules/static_nginx.nix
index 93441cf0..6e87e985 100644
--- a/lass/3modules/static_nginx.nix
+++ b/lass/3modules/static_nginx.nix
@@ -42,10 +42,6 @@ let
certificate_key = mkOption {
type = str;
};
- ciphers = mkOption {
- type = str;
- default = "AES128+EECDH:AES128+EDH";
- };
};
});
default = {};
@@ -74,16 +70,7 @@ let
deny all;
'')
];
-
- listen = (if ssl.enable then
- [ "80" "443 ssl" ]
- else
- "80"
- );
- extraConfig = (if ssl.enable then ''
- ssl_certificate ${ssl.certificate};
- ssl_certificate_key ${ssl.certificate_key};
- '' else "");
+ inherit ssl;
});
};