summaryrefslogtreecommitdiffstats
path: root/lass/3modules/screenlock.nix
diff options
context:
space:
mode:
authornin <nineinchnade@gmail.com>2017-10-20 22:10:49 +0200
committernin <nineinchnade@gmail.com>2017-10-20 22:10:49 +0200
commit506c9ee6c1633f1d2b85aaac20915d7c33f67e7e (patch)
tree959d43238110c8d24ec9de095189d9dab09f9e30 /lass/3modules/screenlock.nix
parent10850a202732728f4b95da7208005617606c2062 (diff)
parent9064b8e5ce92c3380b8765d55e5ba722361286aa (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/3modules/screenlock.nix')
-rw-r--r--lass/3modules/screenlock.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/lass/3modules/screenlock.nix b/lass/3modules/screenlock.nix
new file mode 100644
index 00000000..cf38f835
--- /dev/null
+++ b/lass/3modules/screenlock.nix
@@ -0,0 +1,37 @@
+{ pkgs, config, ... }:
+
+with import <stockholm/lib>;
+
+let
+ cfg = config.lass.screenlock;
+
+ out = {
+ options.lass.screenlock = api;
+ config = mkIf cfg.enable imp;
+ };
+
+ api = {
+ enable = mkEnableOption "news";
+ command = mkOption {
+ type = types.str;
+ default = "${pkgs.i3lock}/bin/i3lock -i /var/lib/wallpaper/wallpaper -f";
+ };
+ };
+
+ imp = {
+ systemd.services.screenlock = {
+ before = [ "sleep.target" ];
+ wantedBy = [ "sleep.target" ];
+ environment = {
+ DISPLAY = ":0";
+ };
+ serviceConfig = {
+ SyslogIdentifier = "screenlock";
+ ExecStart = cfg.command;
+ Type = "forking";
+ User = "lass";
+ };
+ };
+ };
+
+in out