summaryrefslogtreecommitdiffstats
path: root/lass/3modules/hosts.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-10-13 20:33:45 +0200
committertv <tv@krebsco.de>2016-10-13 20:33:45 +0200
commit65165f422d8e08f29ec269a3ce98e7ebfa22c622 (patch)
tree13d15f63626129c439840a4b406e3fe4e693096f /lass/3modules/hosts.nix
parent38d26c551cf3c53151120646a893a13990b21c5c (diff)
parent8458ffd7a00a3e4c734755de7d72f95458d1bb52 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/3modules/hosts.nix')
-rw-r--r--lass/3modules/hosts.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/lass/3modules/hosts.nix b/lass/3modules/hosts.nix
new file mode 100644
index 00000000..f2ff10c0
--- /dev/null
+++ b/lass/3modules/hosts.nix
@@ -0,0 +1,12 @@
+{ config, ... }:
+
+with config.krebs.lib;
+
+{
+ options.lass.hosts = mkOption {
+ type = types.attrsOf types.host;
+ default =
+ filterAttrs (_: host: host.owner.name == "lass")
+ config.krebs.hosts;
+ };
+}