summaryrefslogtreecommitdiffstats
path: root/lass/3modules/bindfs.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2021-01-25 11:28:26 +0100
committertv <tv@krebsco.de>2021-01-25 11:28:26 +0100
commita0ca091cbf4e9ca41390ad9d54844c9eb2660406 (patch)
treeaae89f223f953a81da400d6f7deac1d5ae5d240e /lass/3modules/bindfs.nix
parent1cd73df0c8694f491d40f93a796ea58f150e88dc (diff)
parent71206dc6a2852dd69664e85aa6dcb49676ec1f6e (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/3modules/bindfs.nix')
-rw-r--r--lass/3modules/bindfs.nix51
1 files changed, 0 insertions, 51 deletions
diff --git a/lass/3modules/bindfs.nix b/lass/3modules/bindfs.nix
deleted file mode 100644
index 5c8df8dc5..000000000
--- a/lass/3modules/bindfs.nix
+++ /dev/null
@@ -1,51 +0,0 @@
-with import <stockholm/lib>;
-{ config, pkgs, ... }:
-let
- cfg = config.lass.bindfs;
-in {
- options.lass.bindfs = mkOption {
- type = types.attrsOf (types.submodule ({ config, ... }: {
- options = {
- target = mkOption {
- description = ''
- destination where bindfs mounts to.
- second positional argument to bindfs.
- '';
- default = config._module.args.name;
- type = types.absolute-pathname;
- };
- source = mkOption {
- description = ''
- source folder where the mounted directory is originally.
- first positional argument to bindfs.
- '';
- type = types.absolute-pathname;
- };
- options = mkOption {
- description = ''
- additional arguments to bindfs
- '';
- type = types.listOf types.str;
- default = [];
- };
- };
- }));
- default = {};
- };
-
- config = mkIf (cfg != {}) {
- systemd.services = mapAttrs' (n: mount: let
- name = replaceStrings [ "/" ] [ "_" ] n;
- in nameValuePair "bindfs-${name}" {
- wantedBy = [ "local-fs.target" ];
- path = [ pkgs.coreutils ];
- serviceConfig = {
- ExecStartPre = pkgs.writeDash "bindfs-init-${name}" ''
- mkdir -p '${mount.source}'
- mkdir -p '${mount.target}'
- '';
- ExecStart = "${pkgs.bindfs}/bin/bindfs -f ${concatStringsSep " " mount.options} ${mount.source} ${mount.target}";
- };
- }) cfg;
- };
-}