summaryrefslogtreecommitdiffstats
path: root/lass/2configs/zsh.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-10-23 21:02:02 +0200
committermakefu <github@syntax-fehler.de>2020-10-23 21:02:02 +0200
commite8b6cc0587929a7ebd0d00f83d298640b20b055f (patch)
treee0f813b8264119a84d6b8c32fa68041c8541ab59 /lass/2configs/zsh.nix
parentfd41a76d4cab2765f9ef95ce5322b7bffe52b8a7 (diff)
parent242530680d5dcb37a5a023d0b8f6155ab441cead (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/2configs/zsh.nix')
-rw-r--r--lass/2configs/zsh.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/lass/2configs/zsh.nix b/lass/2configs/zsh.nix
index 05964eb5..e65cdd97 100644
--- a/lass/2configs/zsh.nix
+++ b/lass/2configs/zsh.nix
@@ -122,14 +122,15 @@
case $TERM in
(*xterm* | *rxvt*)
function precmd {
- PROMPT_EVALED="$(print -P $TITLE)"
+ PROMPT_EVALED=$(print -P "$TITLE")
echo -ne "\033]0;$$ $PROMPT_EVALED\007"
}
- # This is seen while the shell waits for a command to complete.
- function preexec {
- PROMPT_EVALED="$(print -P $TITLE)"
- echo -ne "\033]0;$$ $PROMPT_EVALED $1\007"
- }
+ # This seems broken for some reason
+ # # This is seen while the shell waits for a command to complete.
+ # function preexec {
+ # PROMPT_EVALED=$(print -P "$TITLE")
+ # echo -ne "\033]0;$$ $PROMPT_EVALED $1\007"
+ # }
;;
esac
'';