summaryrefslogtreecommitdiffstats
path: root/lass/2configs/zsh.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-01 17:19:26 +0200
committertv <tv@shackspace.de>2015-10-01 17:19:26 +0200
commit39d07cad033cf611d6cede6a6e13bdeaf9a6bd74 (patch)
treeb6ecd7f54577a1a422f3b9d96e4e7c645c71a276 /lass/2configs/zsh.nix
parentcd61f94ba02c485327547ace8cd28a22e38bfe0f (diff)
parente97401da8a402698411b77e88b4a32d388c2ab6f (diff)
Merge remote-tracking branch 'mors/master'
Diffstat (limited to 'lass/2configs/zsh.nix')
-rw-r--r--lass/2configs/zsh.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/lass/2configs/zsh.nix b/lass/2configs/zsh.nix
index 646e816f..64aa4582 100644
--- a/lass/2configs/zsh.nix
+++ b/lass/2configs/zsh.nix
@@ -57,7 +57,7 @@
#exports
export EDITOR='vim'
export MANPAGER='most'
- export PAGER='vim -'
+ export PAGER='vim -R -'
# export MANPAGER='sed -r "s/\x1B\[([0-9]{1,2}(;[0-9]{1,2})?)?[m|K]//g" | vim -R -c "set ft=man nonu nomod nolist" -'
#beautiful colors
@@ -103,23 +103,21 @@
case $UID in
0)
- username='%F{red}root%f'
+ username='%F{red}root%f '
;;
1337)
username=""
;;
*)
- username='%F{blue}%n%f'
+ username='%F{blue}%n%f '
;;
esac
if test -n "$SSH_CLIENT"; then
PROMPT="$error$username@%F{magenta}%M%f %~ "
else
- PROMPT="$error$username %~ "
+ PROMPT="$error$username%~ "
fi
-
-
'';
};
users.defaultUserShell = "/run/current-system/sw/bin/zsh";