summaryrefslogtreecommitdiffstats
path: root/lass/2configs/wine.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-29 14:56:06 +0200
committermakefu <github@syntax-fehler.de>2015-07-29 14:56:06 +0200
commit0bf2b871dda30231443324588ab8142e125e9774 (patch)
tree0646d45eab135eb2c7d8665c31d7ac135e29afff /lass/2configs/wine.nix
parent671710c573980d859cb82993cd0514058a63262f (diff)
parent1bf670270c1e87900a908f7e9b949b5502158f4f (diff)
merge cloudkrebs, fix path to krebs/4lib
Diffstat (limited to 'lass/2configs/wine.nix')
-rw-r--r--lass/2configs/wine.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/lass/2configs/wine.nix b/lass/2configs/wine.nix
new file mode 100644
index 00000000..8d55da7f
--- /dev/null
+++ b/lass/2configs/wine.nix
@@ -0,0 +1,23 @@
+{ config, pkgs, ... }:
+
+let
+ mainUser = config.users.extraUsers.mainUser;
+
+in {
+ environment.systemPackages = with pkgs; [
+ wineUnstable
+ ];
+ users.extraUsers = {
+ wine = {
+ name = "wine";
+ description = "user for running wine";
+ home = "/home/wine";
+ useDefaultShell = true;
+ extraGroups = [ "audio" ];
+ createHome = true;
+ };
+ };
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(wine) NOPASSWD: ALL
+ '';
+}