summaryrefslogtreecommitdiffstats
path: root/lass/2configs/realwallpaper.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-11-10 22:05:40 +0100
committermakefu <github@syntax-fehler.de>2018-11-10 22:05:40 +0100
commite3efeb6dd5da00964ac6157df5920dc034482ef7 (patch)
tree1dff7e22bf632b4508a75a3d096f22b93aaf8c74 /lass/2configs/realwallpaper.nix
parent0c235a88a8391a6c3b67573f85fc03931e5402a2 (diff)
parent30a6c5219a120b7323e46c621a21da7ab8fc1d29 (diff)
Merge remote-tracking branch 'lassul.us/master'
Diffstat (limited to 'lass/2configs/realwallpaper.nix')
-rw-r--r--lass/2configs/realwallpaper.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/lass/2configs/realwallpaper.nix b/lass/2configs/realwallpaper.nix
index 116d6627..e0cb37f6 100644
--- a/lass/2configs/realwallpaper.nix
+++ b/lass/2configs/realwallpaper.nix
@@ -1,4 +1,4 @@
-{ config, lib, ... }:
+{ config, lib, pkgs, ... }:
let
hostname = config.krebs.build.host.name;
@@ -9,6 +9,9 @@ let
in {
krebs.realwallpaper.enable = true;
+ system.activationScripts.user-shadow = ''
+ ${pkgs.coreutils}/bin/chmod +x /var/realwallpaper
+ '';
services.nginx.virtualHosts.wallpaper = {
extraConfig = ''
if ( $server_addr = "${config.krebs.build.host.nets.internet.ip4.addr}" ) {
@@ -22,10 +25,7 @@ in {
locations."/realwallpaper.png".extraConfig = ''
root /var/realwallpaper/;
'';
- locations."/realwallpaper-sat.png".extraConfig = ''
- root /var/realwallpaper/;
- '';
- locations."/realwallpaper-sat-krebs.png".extraConfig = ''
+ locations."/realwallpaper-krebs.png".extraConfig = ''
root /var/realwallpaper/;
'';
};