summaryrefslogtreecommitdiffstats
path: root/lass/2configs/radio.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-01-25 23:23:29 +0100
committermakefu <github@syntax-fehler.de>2017-01-25 23:23:29 +0100
commitbf405736962fd20df738f84665e5fc7f8d74e72d (patch)
treeae01054fe88089d6476b3c1b1952066fd6c79092 /lass/2configs/radio.nix
parent7e1bd2729e11e5c63749c69093359de0bb3329b2 (diff)
parent89c5b22129d3cb875d16a3171a4e3ab3bee9cb0a (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/2configs/radio.nix')
-rw-r--r--lass/2configs/radio.nix39
1 files changed, 15 insertions, 24 deletions
diff --git a/lass/2configs/radio.nix b/lass/2configs/radio.nix
index 18574471..6e96f884 100644
--- a/lass/2configs/radio.nix
+++ b/lass/2configs/radio.nix
@@ -60,28 +60,20 @@ in {
musicDirectory = "/home/radio/the_playlist/music";
extraConfig = ''
audio_output {
- type "shout"
- encoding "ogg"
- name "the_playlist"
- host "localhost"
- port "8000"
- mount "/radio.ogg"
-
- # This is the source password in icecast.xml
- password "${source-password}"
-
- # Set either quality or bit rate
- # quality "5.0"
- bitrate "128"
-
- format "44100:16:1"
-
- # Optional Parameters
- user "source"
- # description "here is my long description"
- genre "good music"
- } # end of audio_output
-
+ type "shout"
+ encoding "ogg"
+ name "the_playlist"
+ host "localhost"
+ port "8000"
+ mount "/radio.ogg"
+ password "${source-password}"
+ bitrate "128"
+
+ format "44100:16:2"
+
+ user "source"
+ genre "good music"
+ }
'';
};
@@ -138,8 +130,7 @@ in {
};
};
- krebs.Reaktor = {
- enable = true;
+ krebs.Reaktor.playlist = {
nickname = "the_playlist|r";
channels = [ "#the_playlist" ];
extraEnviron = {