summaryrefslogtreecommitdiffstats
path: root/lass/2configs/downloading.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-12-07 13:20:49 +0100
committertv <tv@krebsco.de>2018-12-07 13:20:49 +0100
commit1d3a3c8104eac3e9a4ee7cdd961fcd61f706d173 (patch)
tree53ad5d4d3ecc88eeabba682fd1741bf3d1d96aa8 /lass/2configs/downloading.nix
parentbfcf6ad0adaedf0d069850824fbbb55e4af20c5e (diff)
parent43be8e6bb38ea99ed489a8b6633ebb33b96b6282 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/2configs/downloading.nix')
-rw-r--r--lass/2configs/downloading.nix65
1 files changed, 0 insertions, 65 deletions
diff --git a/lass/2configs/downloading.nix b/lass/2configs/downloading.nix
deleted file mode 100644
index 8d0fb0d0..00000000
--- a/lass/2configs/downloading.nix
+++ /dev/null
@@ -1,65 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-
-{
- users.extraUsers = {
- download = {
- name = "download";
- home = "/var/download";
- createHome = true;
- useDefaultShell = true;
- extraGroups = [
- "download"
- ];
- openssh.authorizedKeys.keys = with config.krebs.users; [
- lass.pubkey
- lass-shodan.pubkey
- lass-icarus.pubkey
- lass-daedalus.pubkey
- lass-helios.pubkey
- makefu.pubkey
- wine-mors.pubkey
- ];
- };
-
- transmission = {
- extraGroups = [
- "download"
- ];
- };
- };
-
- users.extraGroups = {
- download = {
- members = [
- "download"
- "transmission"
- ];
- };
- };
-
- krebs.rtorrent = {
- enable = true;
- web = {
- enable = true;
- port = 9091;
- basicAuth = import <secrets/torrent-auth>;
- };
- rutorrent.enable = true;
- enableXMLRPC = true;
- listenPort = 51413;
- downloadDir = "/var/download/finished";
- # dump old torrents into watch folder to have them re-added
- watchDir = "/var/download/watch";
- };
-
- krebs.iptables = {
- enable = true;
- tables.filter.INPUT.rules = [
- { predicate = "-p tcp --dport 9091"; target = "ACCEPT"; }
- { predicate = "-p tcp --dport 51413"; target = "ACCEPT"; }
- { predicate = "-p udp --dport 51413"; target = "ACCEPT"; }
- ];
- };
-}