summaryrefslogtreecommitdiffstats
path: root/lass/2configs/buildbot-standalone.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-08-07 09:54:10 +0200
committertv <tv@krebsco.de>2016-08-07 09:54:10 +0200
commit3288d6848f774e00a5fbc2ba060f2df695af8e55 (patch)
tree971a8ae4fd7b64d2c5b9374d6707d7dc2bb79beb /lass/2configs/buildbot-standalone.nix
parent3a760096f6b3b49d4bf32465c860ccfd23d174fa (diff)
parentcbf66556afed7220bc95d1716f06cede5a7a8b09 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/2configs/buildbot-standalone.nix')
-rw-r--r--lass/2configs/buildbot-standalone.nix58
1 files changed, 38 insertions, 20 deletions
diff --git a/lass/2configs/buildbot-standalone.nix b/lass/2configs/buildbot-standalone.nix
index 766fd715..90a99033 100644
--- a/lass/2configs/buildbot-standalone.nix
+++ b/lass/2configs/buildbot-standalone.nix
@@ -8,9 +8,6 @@ let
ControlPath /tmp/%u_sshmux_%r@%h:%p
ControlPersist 4h
'';
- sshWrapper = pkgs.writeDash "ssh-wrapper" ''
- ${pkgs.openssh}/bin/ssh -F ${sshHostConfig} -i ${shell.escape config.lass.build-ssh-privkey.path} "$@"
- '';
in {
config.krebs.buildbot.master = let
@@ -66,10 +63,15 @@ in {
"NIX_REMOTE": "daemon",
"dummy_secrets": "true",
}
+ env_shared = {
+ "LOGNAME": "shared",
+ "NIX_REMOTE": "daemon",
+ "dummy_secrets": "true",
+ }
# prepare nix-shell
# the dependencies which are used by the test script
- deps = [ "gnumake", "jq", "nix", "(import <stockholm>).pkgs.populate" ]
+ deps = [ "gnumake", "jq", "nix", "(import <stockholm>).pkgs.populate", "openssh" ]
# TODO: --pure , prepare ENV in nix-shell command:
# SSL_CERT_FILE,LOGNAME,NIX_REMOTE
nixshell = ["nix-shell",
@@ -88,20 +90,20 @@ in {
for i in [ "mors", "uriel", "shodan", "helios", "cloudkrebs", "echelon", "dishfire", "prism" ]:
addShell(f,name="build-{}".format(i),env=env_lass,
command=nixshell + \
- ["make \
+ ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
+ make \
test \
- ssh=${sshWrapper} \
- target=build@localhost${config.users.users.build.home}/testbuild \
+ target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
method=build \
system={}".format(i)])
for i in [ "x", "wry", "vbob", "wbob", "shoney" ]:
addShell(f,name="build-{}".format(i),env=env_makefu,
command=nixshell + \
- ["make \
+ ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
+ make \
test \
- ssh=${sshWrapper} \
- target=build@localhost${config.users.users.build.home}/testbuild \
+ target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
method=build \
system={}".format(i)])
@@ -114,19 +116,35 @@ in {
fast-tests = ''
f = util.BuildFactory()
f.addStep(grab_repo)
- for i in [ "prism", "mors", "echelon" ]:
- addShell(f,name="populate-{}".format(i),env=env_lass,
+ for i in [ "mors", "uriel", "shodan", "helios", "cloudkrebs", "echelon", "dishfire", "prism" ]:
+ addShell(f,name="build-{}".format(i),env=env_lass,
+ command=nixshell + \
+ ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
+ make \
+ test \
+ target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
+ method=eval \
+ system={}".format(i)])
+
+ for i in [ "x", "wry", "vbob", "wbob", "shoney" ]:
+ addShell(f,name="build-{}".format(i),env=env_makefu,
command=nixshell + \
- ["{}(make system={} populate debug=true)".format("!" if "failing" in i else "",i)])
+ ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
+ make \
+ test \
+ target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
+ method=eval \
+ system={}".format(i)])
- addShell(f,name="build-test-minimal",env=env_lass,
+ for i in [ "test-minimal-deploy", "test-all-krebs-modules", "wolf" ]:
+ addShell(f,name="build-{}".format(i),env=env_shared,
command=nixshell + \
- ["nix-instantiate \
- --show-trace --eval --strict --json \
- -I nixos-config=./shared/1systems/test-minimal-deploy.nix \
- -I secrets=. \
- -A config.system.build.toplevel"]
- )
+ ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
+ make \
+ test \
+ target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
+ method=eval \
+ system={}".format(i)])
bu.append(util.BuilderConfig(name="fast-tests",
slavenames=slavenames,