summaryrefslogtreecommitdiffstats
path: root/lass/2configs/ableton.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-01-05 21:14:15 +0100
committerjeschli <jeschli@gmail.com>2018-01-05 21:14:15 +0100
commit183b001e1aca601e420ef07ec4944a15c13a8d2c (patch)
tree9d34f79c2ee7cb073a39ab44ef2795055a42d067 /lass/2configs/ableton.nix
parentea85e788ae2a6ca24ccb997372542f7f2a104080 (diff)
parente083b18e34519f30bba79dfd894c3b828fd13da7 (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'lass/2configs/ableton.nix')
-rw-r--r--lass/2configs/ableton.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/lass/2configs/ableton.nix b/lass/2configs/ableton.nix
new file mode 100644
index 00000000..9d6f481b
--- /dev/null
+++ b/lass/2configs/ableton.nix
@@ -0,0 +1,20 @@
+{ config, pkgs, ... }: let
+ mainUser = config.users.extraUsers.mainUser;
+in {
+ users.users= {
+ ableton = {
+ isNormalUser = true;
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ packages = [
+ pkgs.wine
+ pkgs.winetricks
+ ];
+ };
+ };
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(ableton) NOPASSWD: ALL
+ '';
+}