summaryrefslogtreecommitdiffstats
path: root/lass/2configs/IM.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-01-04 00:21:13 +0100
committermakefu <github@syntax-fehler.de>2018-01-04 00:21:13 +0100
commit8c6bd7431c8620fa65466e880fbd38e2c555367d (patch)
tree9d73f67cf751a6f3f99b6a5a0c3dd0ddaee16382 /lass/2configs/IM.nix
parent6ad170e7621668fdcf03aab37d1f9843e446d2da (diff)
parenta9f803207243425d5c06ce82820c27a4de8af5ad (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/2configs/IM.nix')
-rw-r--r--lass/2configs/IM.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/lass/2configs/IM.nix b/lass/2configs/IM.nix
new file mode 100644
index 00000000..b94cb063
--- /dev/null
+++ b/lass/2configs/IM.nix
@@ -0,0 +1,57 @@
+with (import <stockholm/lib>);
+{ config, lib, pkgs, ... }:
+
+let
+ tmux = pkgs.writeDash "tmux" ''
+ exec ${pkgs.tmux}/bin/tmux -f ${pkgs.writeText "tmux.conf" ''
+ set-option -g prefix `
+ unbind-key C-b
+ bind ` send-prefix
+
+ set-option -g status off
+ set-option -g default-terminal screen-256color
+
+ #use session instead of windows
+ bind-key c new-session
+ bind-key p switch-client -p
+ bind-key n switch-client -n
+ bind-key C-s switch-client -l
+ ''} "$@"
+ '';
+in {
+
+ users.extraUsers.chat = {
+ home = "/home/chat";
+ uid = genid "chat";
+ useDefaultShell = true;
+ createHome = true;
+ openssh.authorizedKeys.keys = with config.krebs.users; [
+ lass.pubkey
+ lass-shodan.pubkey
+ lass-icarus.pubkey
+ lass-android.pubkey
+ ];
+ };
+
+ # mosh
+ krebs.iptables.tables.filter.INPUT.rules = [
+ { predicate = "-p udp --dport 60000:61000"; target = "ACCEPT";}
+ { predicate = "-p tcp --dport 9999"; target = "ACCEPT";}
+ ];
+
+ systemd.services.chat = {
+ description = "chat environment setup";
+ after = [ "network.target" ];
+ wantedBy = [ "multi-user.target" ];
+
+ restartIfChanged = false;
+
+ serviceConfig = {
+ User = "chat";
+ RemainAfterExit = true;
+ Type = "oneshot";
+ ExecStart = "${tmux} -2 new-session -d -s IM ${pkgs.weechat}/bin/weechat";
+ ExecStop = "${tmux} kill-session -t IM";
+ };
+ };
+}