summaryrefslogtreecommitdiffstats
path: root/lass/1systems/xerxes/physical.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-09-24 17:08:52 +0200
committermakefu <github@syntax-fehler.de>2019-09-24 17:08:52 +0200
commit78687ea2a8507de5e3af2a44b71dd47798daf85b (patch)
treed9a7e1548f0fc0c555478f9c7191aa6e81027db1 /lass/1systems/xerxes/physical.nix
parent4bb7a52e98c1297655d77af661637545de906493 (diff)
parent20e38840fed74e5a71342c1ba335a6bf0ad5080a (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/1systems/xerxes/physical.nix')
-rw-r--r--lass/1systems/xerxes/physical.nix24
1 files changed, 12 insertions, 12 deletions
diff --git a/lass/1systems/xerxes/physical.nix b/lass/1systems/xerxes/physical.nix
index f88578e1..5d60dfc4 100644
--- a/lass/1systems/xerxes/physical.nix
+++ b/lass/1systems/xerxes/physical.nix
@@ -17,6 +17,7 @@
boot.blacklistedKernelModules = [
"goodix"
];
+
boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "sd_mod" ];
boot.initrd.kernelModules = [ ];
boot.initrd.luks.devices.crypted.device = "/dev/sda3";
@@ -27,11 +28,6 @@
"boot.shell_on_fail"
];
- services.xserver.displayManager.sessionCommands = ''
- (sleep 2 && ${pkgs.xorg.xrandr}/bin/xrandr --output eDP-1 --rotate right)
- (sleep 2 && ${pkgs.xorg.xinput}/bin/xinput set-prop 'Goodix Capacitive TouchScreen' 'Coordinate Transformation Matrix' 0 1 0 -1 0 1 0 0 1)
- '';
-
fileSystems."/" = {
device = "rpool/root";
fsType = "zfs";
@@ -76,11 +72,15 @@
IdleActionSec=300
'';
- services.xserver.extraConfig = ''
- Section "Device"
- Identifier "Intel Graphics"
- Driver "Intel"
- Option "TearFree" "true"
- EndSection
- '';
+ services.xserver = {
+ videoDrivers = [ "intel" ];
+ deviceSection = ''
+ Option "TearFree" "true"
+ '';
+ displayManager.sessionCommands = ''
+ echo nonono > /tmp/xxyy
+ (sleep 2 && ${pkgs.xorg.xrandr}/bin/xrandr --output eDP1 --rotate right)
+ (sleep 2 && ${pkgs.xorg.xinput}/bin/xinput set-prop 'Goodix Capacitive TouchScreen' 'Coordinate Transformation Matrix' 0 1 0 -1 0 1 0 0 1)
+ '';
+ };
}