summaryrefslogtreecommitdiffstats
path: root/lass/1systems/prism/config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-06-24 23:43:26 +0200
committermakefu <github@syntax-fehler.de>2018-06-24 23:43:26 +0200
commit1b37e5d649f124c6d85fa59d22116e330fe7d032 (patch)
tree541efd446c4dc9c5227feb04d432ccc3c4f1e92c /lass/1systems/prism/config.nix
parent522148ec0e642b739b79de16aa7fe51832f90a30 (diff)
parent9c2584b3c841dc75b1a3a34c252a5a91495d06a2 (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'lass/1systems/prism/config.nix')
-rw-r--r--lass/1systems/prism/config.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/lass/1systems/prism/config.nix b/lass/1systems/prism/config.nix
index 9a0bb49e..78040381 100644
--- a/lass/1systems/prism/config.nix
+++ b/lass/1systems/prism/config.nix
@@ -281,6 +281,18 @@ with import <stockholm/lib>;
];
}
{
+ services.nginx = {
+ enable = true;
+ virtualHosts."radio.lassul.us" = {
+ forceSSL = true;
+ enableACME = true;
+ locations."/".extraConfig = ''
+ proxy_pass http://localhost:8000;
+ '';
+ };
+ };
+ }
+ {
lass.nichtparasoup.enable = true;
services.nginx = {
enable = true;
@@ -341,6 +353,14 @@ with import <stockholm/lib>;
{ predicate = "-p udp --dport 60000:61000"; target = "ACCEPT";}
];
}
+ {
+ services.murmur.enable = true;
+ services.murmur.registerName = "lassul.us";
+ krebs.iptables.tables.filter.INPUT.rules = [
+ { predicate = "-p tcp --dport 64738"; target = "ACCEPT";}
+ ];
+
+ }
];
krebs.build.host = config.krebs.hosts.prism;