summaryrefslogtreecommitdiffstats
path: root/lass/1systems/prism.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-09-07 14:58:31 +0200
committermakefu <github@syntax-fehler.de>2016-09-07 14:58:31 +0200
commit541e21dcba667707e2fb8eef3bfa53f29f4b26c8 (patch)
tree0fed91b14d2c5bff2715d43ba08e77528f1e0a2d /lass/1systems/prism.nix
parent66ba3c3c37b6c08104e3c7f53a203853a481af26 (diff)
parent69d537f1052a2915d802134caafc4040aae037bf (diff)
Merge remote-tracking branch 'prism/lassulus'
Diffstat (limited to 'lass/1systems/prism.nix')
-rw-r--r--lass/1systems/prism.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/lass/1systems/prism.nix b/lass/1systems/prism.nix
index 47e8a68b..c7c76530 100644
--- a/lass/1systems/prism.nix
+++ b/lass/1systems/prism.nix
@@ -243,6 +243,23 @@ in {
];
};
}
+ {
+ krebs.nginx = {
+ enable = true;
+ servers.public = {
+ listen = [ "8088" ];
+ server-names = [ "default" ];
+ locations = [
+ (nameValuePair "~ ^/~(.+?)(/.*)?\$" ''
+ alias /home/$1/public_html$2;
+ '')
+ ];
+ };
+ };
+ krebs.iptables.tables.filter.INPUT.rules = [
+ { predicate = "-p tcp --dport 8088"; target = "ACCEPT"; }
+ ];
+ }
];
krebs.build.host = config.krebs.hosts.prism;