summaryrefslogtreecommitdiffstats
path: root/lass/1systems/mors.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-02-15 16:57:48 +0100
committerlassulus <lass@aidsballs.de>2016-02-15 16:57:48 +0100
commitcadb62a9f4eda028cf318164000223c2d566131a (patch)
tree8c72f9092156ed530a3febf72bfcad0129a93a96 /lass/1systems/mors.nix
parent1ab712900c5ebc9a53f9593c9e7d7424031b2073 (diff)
l 1 mors: add python test-env
Diffstat (limited to 'lass/1systems/mors.nix')
-rw-r--r--lass/1systems/mors.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/lass/1systems/mors.nix b/lass/1systems/mors.nix
index ebce9395..26a820cf 100644
--- a/lass/1systems/mors.nix
+++ b/lass/1systems/mors.nix
@@ -96,6 +96,39 @@
# { predicate = "-i retiolum -p tcp --dport 80"; target = "ACCEPT"; precedence = 9998; }
# ];
#}
+ {
+ containers.pythonenv = {
+ config = {
+ services.openssh.enable = true;
+ users.users.root.openssh.authorizedKeys.keys = [
+ config.krebs.users.lass.pubkey
+ ];
+
+ environment = {
+ systemPackages = with pkgs; [
+ git
+ libxml2
+ libxslt
+ libzip
+ python27Full
+ python27Packages.buildout
+ stdenv
+ zlib
+ ];
+
+ pathsToLink = [ "/include" ];
+
+ shellInit = ''
+ # help pip to find libz.so when building lxml
+ export LIBRARY_PATH=/var/run/current-system/sw/lib
+ # ditto for header files, e.g. sqlite
+ export C_INCLUDE_PATH=/var/run/current-system/sw/include
+ '';
+ };
+
+ };
+ };
+ }
];
krebs.build.host = config.krebs.hosts.mors;