summaryrefslogtreecommitdiffstats
path: root/lass/1systems/dishfire/physical.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-05-31 10:39:49 +0200
committermakefu <github@syntax-fehler.de>2018-05-31 10:39:49 +0200
commit10deb114affc296224df59a5e4a3161101548613 (patch)
treecdb0aec231ee0d5354003e6d0d2d4df38db22f82 /lass/1systems/dishfire/physical.nix
parent319bb6fa89e24d0da9eca1b9d69c685b95f329f0 (diff)
parent4277c251906100bc103808af7a674fe2fbb3851b (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/1systems/dishfire/physical.nix')
-rw-r--r--lass/1systems/dishfire/physical.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/lass/1systems/dishfire/physical.nix b/lass/1systems/dishfire/physical.nix
new file mode 100644
index 00000000..64e3904e
--- /dev/null
+++ b/lass/1systems/dishfire/physical.nix
@@ -0,0 +1,39 @@
+{ config, lib, pkgs, ... }:
+{
+ imports = [
+ ./config.nix
+ <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
+ ];
+
+ boot.loader.grub = {
+ device = "/dev/vda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ata_piix"
+ "ehci_pci"
+ "uhci_hcd"
+ "virtio_pci"
+ "virtio_blk"
+ ];
+
+ fileSystems."/" = {
+ device = "/dev/mapper/pool-nix";
+ fsType = "ext4";
+ };
+
+ fileSystems."/srv/http" = {
+ device = "/dev/pool/srv_http";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" = {
+ device = "/dev/vda1";
+ fsType = "ext4";
+ };
+ fileSystems."/bku" = {
+ device = "/dev/pool/bku";
+ fsType = "ext4";
+ };
+}