summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/tarantool/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-08-21 12:12:13 +0200
committermakefu <github@syntax-fehler.de>2016-08-21 12:12:13 +0200
commit054475b6230ec357523b9eed143667a11db92966 (patch)
treedd60906a6b0f6a5d2252536a50044d42e6098915 /krebs/5pkgs/tarantool/default.nix
parent54ccd367175e33c0aab67e8ef46d4d73bcf8183c (diff)
parent1d9f7b4f2d1a444bb7b19f18efa3bee63c8d3770 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'krebs/5pkgs/tarantool/default.nix')
-rw-r--r--krebs/5pkgs/tarantool/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/krebs/5pkgs/tarantool/default.nix b/krebs/5pkgs/tarantool/default.nix
new file mode 100644
index 00000000..9e22fd4f
--- /dev/null
+++ b/krebs/5pkgs/tarantool/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchgit, cmake, ncurses, openssl, readline, ... }:
+
+stdenv.mkDerivation rec {
+ name = "tarantool-1.7.1-164-g0fd0239";
+ src = fetchgit {
+ url = https://github.com/tarantool/tarantool;
+ rev = builtins.elemAt (builtins.match ".*-g([0-9a-f]+)" name) 0;
+ sha256 = "1jnaiizbl9j4a8vsihqx75iqa9bkh1kpwsyrgmim8ikiyzfw54dz";
+ fetchSubmodules = true;
+ };
+ buildInputs = [
+ cmake
+ ncurses
+ openssl
+ readline
+ ];
+ preConfigure = ''
+ echo ${(builtins.parseDrvName name).version} > VERSION
+ sed -i 's/NAMES termcap/NAMES ncurses/' cmake/FindTermcap.cmake
+ '';
+}