summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/buildbot-classic-slave/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-07-28 13:31:15 +0200
committermakefu <github@syntax-fehler.de>2017-07-28 13:31:15 +0200
commit44e521a5745807f4c19e7c56b9f4d0266f89b3e4 (patch)
tree11396e2c39d251ceb1018f34f2cc5a38bd722459 /krebs/5pkgs/simple/buildbot-classic-slave/default.nix
parent421c27332a69708afd81a5fb07a28fdc93449338 (diff)
parente8148b62fdb39ed76361da5b7a6de88a8f800073 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'krebs/5pkgs/simple/buildbot-classic-slave/default.nix')
-rw-r--r--krebs/5pkgs/simple/buildbot-classic-slave/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/buildbot-classic-slave/default.nix b/krebs/5pkgs/simple/buildbot-classic-slave/default.nix
new file mode 100644
index 00000000..c316889e
--- /dev/null
+++ b/krebs/5pkgs/simple/buildbot-classic-slave/default.nix
@@ -0,0 +1,21 @@
+{ coreutils, fetchgit, fetchFromGitHub, buildbot-classic, python2Packages, ... }:
+
+python2Packages.buildPythonApplication {
+ name = "buildbot-classic-slave-0.8.12";
+ namePrefix = "";
+
+ src = buildbot-classic.src;
+ postUnpack = "sourceRoot=\${sourceRoot}/slave";
+
+ patchPhase = ''
+ substituteInPlace buildslave/scripts/logwatcher.py --replace /usr/bin/tail ${coreutils}/bin/tail
+ '';
+
+ propagatedBuildInputs = [ python2Packages.twisted ];
+ doCheck = false;
+
+ postInstall = ''
+ mkdir -p "$out/share/man/man1"
+ cp docs/buildslave.1 "$out/share/man/man1"
+ '';
+}