summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/hyphenation.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-06-01 10:08:56 +0200
committermakefu <github@syntax-fehler.de>2017-06-01 10:08:56 +0200
commit772f84305d90380e0d221cf49ae3f1597d0d0510 (patch)
tree8d2241648396dc34fa96c8c68e12f832fbc7c308 /krebs/5pkgs/haskell/hyphenation.nix
parent90822f64e0bf247c5cca2f035077553cac5ceb79 (diff)
parent21d92086fe00c7369fde3951f92e9f73f4c05ee9 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'krebs/5pkgs/haskell/hyphenation.nix')
-rw-r--r--krebs/5pkgs/haskell/hyphenation.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/hyphenation.nix b/krebs/5pkgs/haskell/hyphenation.nix
new file mode 100644
index 00000000..6e5fe945
--- /dev/null
+++ b/krebs/5pkgs/haskell/hyphenation.nix
@@ -0,0 +1,17 @@
+# Same as upstream but with doCheck = false because doctest has wrong version.
+{ mkDerivation, base, bytestring, containers, directory
+, filepath, unordered-containers, zlib, stdenv
+}:
+mkDerivation {
+ pname = "hyphenation";
+ version = "0.6";
+ sha256 = "2f673666c18f63581422f7c6389b78b0ff754406671296a3d680d417942512f7";
+ libraryHaskellDepends = [
+ base bytestring containers unordered-containers zlib
+ ];
+ homepage = "http://github.com/ekmett/hyphenation";
+ description = "Configurable Knuth-Liang hyphenation";
+ license = stdenv.lib.licenses.bsd3;
+ hydraPlatforms = stdenv.lib.platforms.none;
+ doCheck = false;
+}