summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/blessings.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-05-29 10:54:07 +0200
committerlassulus <lass@lassul.us>2017-05-29 10:54:07 +0200
commit35bc9f03a9bea7c6f864b95c95f5c095fa53e92b (patch)
tree059b5dc3b4fee6838b35f272a75dde3bd2ac785b /krebs/5pkgs/haskell/blessings.nix
parent6e93f661e0b31c95f69d1bd3a6f208d26e3e0958 (diff)
parent4d1de57df5800879e7fcfcc38e5a10f0c1b993d7 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'krebs/5pkgs/haskell/blessings.nix')
-rw-r--r--krebs/5pkgs/haskell/blessings.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/blessings.nix b/krebs/5pkgs/haskell/blessings.nix
new file mode 100644
index 00000000..f852b4a4
--- /dev/null
+++ b/krebs/5pkgs/haskell/blessings.nix
@@ -0,0 +1,14 @@
+{ mkDerivation, base, fetchgit, stdenv }:
+mkDerivation rec {
+ pname = "blessings";
+ version = "1.1.0";
+ src = fetchgit {
+ url = http://cgit.ni.krebsco.de/blessings;
+ rev = "refs/tags/v${version}";
+ sha256 = "1k908zap3694fcxdk4bb29s54b0lhdh557y10ybjskfwnym7szn1";
+ };
+ libraryHaskellDepends = [ base ];
+ doHaddock = false;
+ # WTFPL is the true license, which is unknown to cabal.
+ license = stdenv.lib.licenses.wtfpl;
+}