summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/hashPassword.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-08-29 00:36:50 +0200
committertv <tv@shackspace.de>2015-08-29 00:36:50 +0200
commit22a171f3e0405d504e8c8c3b32f73a8087a5ed66 (patch)
tree12d41954273e34f06cfbcf6e12f7fb64c7db2b4d /krebs/5pkgs/hashPassword.nix
parent09257f97823e9a57cda749c2d5a69b18ef484cec (diff)
krebs pkgs += charybdis lentil much
While there, put everything into subdirectories.
Diffstat (limited to 'krebs/5pkgs/hashPassword.nix')
-rw-r--r--krebs/5pkgs/hashPassword.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/krebs/5pkgs/hashPassword.nix b/krebs/5pkgs/hashPassword.nix
deleted file mode 100644
index a10340cc..00000000
--- a/krebs/5pkgs/hashPassword.nix
+++ /dev/null
@@ -1,16 +0,0 @@
-{ lib, pkgs, ... }:
-
-pkgs.writeScriptBin "hashPassword" ''
- #! /bin/sh
- # usage: hashPassword
- set -euf
-
- export PATH=${lib.makeSearchPath "bin" (with pkgs; [
- coreutils
- mkpasswd
- openssl
- ])}
-
- salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
- exec mkpasswd -m sha-512 -S "$salt"
-''