summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/git-hooks
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2016-12-27 22:58:36 +0100
committerlassulus <lass@lassul.us>2016-12-27 22:58:36 +0100
commit3c5906dd62704f0a1cdc14ec7c5c6569d7625dbe (patch)
tree0605e63e2a547a08a9960e5c780ca8fbf66860c1 /krebs/5pkgs/git-hooks
parent568e9e523a70f51886d9850213ee41af27da881b (diff)
k 5: move irc-announce to seperate package
Diffstat (limited to 'krebs/5pkgs/git-hooks')
-rw-r--r--krebs/5pkgs/git-hooks/default.nix64
1 files changed, 1 insertions, 63 deletions
diff --git a/krebs/5pkgs/git-hooks/default.nix b/krebs/5pkgs/git-hooks/default.nix
index 6f2cb8b6..9355a878 100644
--- a/krebs/5pkgs/git-hooks/default.nix
+++ b/krebs/5pkgs/git-hooks/default.nix
@@ -108,67 +108,5 @@ let
fi
'';
- irc-announce-script = pkgs.writeDash "irc-announce-script" ''
- set -euf
-
- export PATH=${makeSearchPath "bin" (with pkgs; [
- coreutils
- gawk
- gnused
- netcat
- nettools
- ])}
-
- IRC_SERVER=$1
- IRC_PORT=$2
- IRC_NICK=$3$$
- IRC_CHANNEL=$4
- message=$5
-
- export IRC_CHANNEL # for privmsg_cat
-
- # echo2 and cat2 are used output to both, stdout and stderr
- # This is used to see what we send to the irc server. (debug output)
- echo2() { echo "$*"; echo "$*" >&2; }
- cat2() { tee /dev/stderr; }
-
- # privmsg_cat transforms stdin to a privmsg
- privmsg_cat() { awk '{ print "PRIVMSG "ENVIRON["IRC_CHANNEL"]" :"$0 }'; }
-
- # ircin is used to feed the output of netcat back to the "irc client"
- # so we can implement expect-like behavior with sed^_^
- # XXX mkselfdestructingtmpfifo would be nice instead of this cruft
- tmpdir="$(mktemp -d irc-announce_XXXXXXXX)"
- cd "$tmpdir"
- mkfifo ircin
- trap "
- rm ircin
- cd '$OLDPWD'
- rmdir '$tmpdir'
- trap - EXIT INT QUIT
- " EXIT INT QUIT
-
- {
- echo2 "USER $LOGNAME 0 * :$LOGNAME@$(hostname)"
- echo2 "NICK $IRC_NICK"
-
- # wait for MODE message
- sed -n '/^:[^ ]* MODE /q'
-
- echo2 "JOIN $IRC_CHANNEL"
-
- printf '%s' "$message" \
- | privmsg_cat \
- | cat2
-
- echo2 "PART $IRC_CHANNEL"
-
- # wait for PART confirmation
- sed -n '/:'"$IRC_NICK"'![^ ]* PART /q'
-
- echo2 'QUIT :Gone to have lunch'
- } < ircin \
- | nc "$IRC_SERVER" "$IRC_PORT" | tee -a ircin
- '';
-
+ irc-announce-script = "${pkgs.irc-announce}/bin/irc-announce";
in out